May 22, 2014

Fix Bootstrap theme error on Drupal using [Jquery update + Libraries ]


 hola chicos ;)


I recently installed Bootstrap theme on my site and enabled it to be my default theme, I noticed my firebug printing errors on my console and all js related features are disabled after the page reload,  which I started to suspect on my jquery file version and eventually I confirmed that version of my file is the culprit.

Drupal 7.x installation comes with the jquery version 1.4.x but as per date 05/2014 it is version 1.11.x so obviously you know why you get that error! I have listed few steps below to get rid of those junks!

Step 1
Install jQuery Update module and configure (admin/config/development/jquery_update) the version you need to make use of.
Note: selecting from cdn i.e(jquery, google) will fix the error for sure, if not follow the other steps down.

Step 2
Install Libraries API module and enable it , Install Bootstrap Libraries module and enable it

Step 3
Now download the latest version of bootstrap files from http://getbootstrap.com/ and extract the files in sites/all/libraries directory by renaming the folder “bootstrap”

Step 4
Make any configurations you need in the page /admin/config/development/bootstrap_library and hit save

The steps above will override all the old/existing jquery version and will be compatible with your bootstrap files.

Step 5
Post any questions or comments and Follow me on twitter @ashkar_rahman.

Follow by Email